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Document Purpose 
This document describes the functionality of ImageSplit. 

Overview 
ImageSplit is an application for selecting parts of an image containing one or more photos. It can 
only be run from Caption Pro, and the extracted photos can be captioned by Caption Pro. 
Images can be loaded directly from a scanner or from image files produced by a scanner or a 
camera. Photos can be detected automatically with a choice of two algorithms, by manually 
defining regions (splits) on the loaded image or a by combination of both methods. The 
detection algorithms have a number of parameters which can be adjusted for optimum results. 
 
Splits are de-skewed and can be sub-divided, rotated, inverted or have their sharpness, contrast 
or brightness adjusted either singly or as a group. Splits can be saved as JPEG files for 
subsequent captioning by Caption Pro.  

 
ImageSplit requires Windows 7 or newer (64-bit operating system) with .Net 4.6.1 Framework. 
It is installed and uninstalled as part of Caption Pro, and can be launched via the File-
>ImageSplit option. If splits are saved, Caption Pro operates on all files contained in the 
ImageSplit save folder. These files can be loaded via the Caption Pro File->Folder(s) option. 

Operation 

Licensing 
The demo license limits the sum of files extracted and captions applied to 25, over a period of 
30 days after installation. A paid license allows permanent unlimited file extraction and 
processing. Major upgrades are included for the license duration. 

Start Screen 
 After File->ImageSplit is clicked from Caption Pro, or after clicking the ImageSplit icon for the 
standalone version, the screen shown below appears: 

 
 
The current automatic detection algorithm (either Floodfill or Rect (rectangle detection)) is 
indicated by the second menu item. 
 Images can be loaded from  files or from a scanner. The scanner and scan resolution are 
selected from the File-> Choose Scanner & DPI menu option: 
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Figure 1 Scanner and Resolution Selection Screen 

 
The connection to scanners uses the Windows Image Acquisition (WIA) protocol, and for 
wireless connections, such as those shown above, the same scanner may appear more than 
once. Either connection will work, but one may have higher resolutions available than the other.  
 
As there are hundreds of different types of scanner in use, connection to all of them via the WIA 
protocol may not be successful. If connection errors or errors in scan operation are 
encountered, the scan should be saved as a 24-bit colour file in any of the following formats: 
JPEG, BMP, TIFF or PNG.  The file should then be loaded into ImageSplit. 
 
The resolution of the scanner defaults to 300 dpi (dots per inch) as this is available on nearly all 
scanners. However, an A4 flatbed scanner with this resolation will generate an image of 
approximately 2400 x 3500 pixels (8.5 megapixels). If the scanned image contains 6 x 4 inch 
photos with a 3:2 aspect ratio, each extracted photo  will be about 2 megapixels in size (2000 x 
1000 pixels). This resolution is adequate for  display on electronic devices, such as phones, 
tablets or standard desktops, but will not be adequate for high-resolution display or printing at 
the common 6 inch by 4 inch paper size. A resolution of 600 dpi is required for this purpose, but 
scanning and processing times will be longer. Smaller photos (as were common  up to the 
middle of the 20th century) will require a higher resolution scan, but result may be particularly 
rewarding, as these small images were often contact prints from large negatives with high 
resolution. 

Image Conditioning for Automatic Detection 
When scanning paper photos it is possible to change the background colour, the scan resolution 
and the colour depth (grey scale or colour). The required resolution is discussed in the previous 
section. The standard scanner background colour is white, which is suitable for colour photos 
but the flood-fill algorithms may fail for black-and-white images using the default threshold 
value where white appears at the edge of the photo. Adjusting the threshold may improve 
performance, but a black background may give better results. Other colour backgrounds may be 
used, but small changes in the colour across the background may occur and prevent the flood-
fill algorithm from working. Changing the background location (by dragging the circle shown at 
the top or side of the image), or using rectangle detection rather than flood-fill may help.  
 
Using greyscale or colour scans on black-and white photos may give different results for each 
algorithm - which is better depends on individual photos. ImageSplit  works in 24-bit colour or 8-
bit greyscale images for any input file format. JPEG format only supports these two bit depths. 
TIFF files support 48-bit colour, but ImageSplit does not work with this bit depth. TIFF also 
supports 16-bit greyscale and ImageSplit will work with these images, but splits will lack 
contrast. 
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Images or scans of photo album pages often have a textured background between photos, 
which may disrupt automatic detection of photos using the flood-fill algorithm.  The Rectangle 
algorithm may give better results. Where there is a colour difference between the background 
and the photos, colour adjustment to make the background close to white may improve the 
performance of the flood-fill algorithm. 
 
Photo albums pose particular problems as shown in the camera image below, which was 
generated using flood-fill detection

 
Figure 2 Photo Album Page 

The first problem is that one of the rectangles detected (shown in the rightmost split) includes 
most of the album page and two other images within it. The background pixel is at the middle of 
the right-hand side. The rectangle enclosing the other two is not precisely square (a tolerance of 
10 degrees is allowed) and the left and right edges are not visible. If this rectangle is not 
deleted, unexpected behaviour may occur if other rectangles are adjusted, 
 
Photo detection from scans of negative strips or contact sheets can be easily accomplished 
using the split subdivision capability, but the resolution should be high enough to make 
individual images displayable on the desired device. For 35 mm negatives or contact sheets, a 
resolution of 1200 dpi will be required for display on mobile phones. Post processing to invert 
individual negative images using a product such as IrfanView will be usually be required. 

Flood-fill algorithm 
The flood-fill detection algorithm used by ImageSplit extracts edges from the image displayed 
on the screen using the Sobel edge filter and then performs a flood-fill from a point outside any 
of the photos contained in the image. The screen image is generated by fitting the scanned 
image or loaded file to the dimensions of the image display area. The loaded image aspect ratio 
is retained and white padding is applied where required. Quadrilaterals with internal angles 
deviating by less than 10 degrees  are then detected in the boundary of the flood-filled region. 
These will commonly be rectangles, but not always as shown below. Note that the split image is 
shown as the largest rectangle fitting within the quadrilateral. 

https://www.irfanview.com/
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Figure 3 Flood-fill detection showing non-rectangular photo at middle left 

Detected regions may also overlap as shown below. In this case one of the splits should be 
deleted before any manipulation is attempted. 

 
Figure 4 Overlapping detected regions 

 
This algorithm is best suited to images with a uniform or slowly varying background between 
the photos, as is obtained by placing individual paper photos on a flatbed scanner. For this 
reason, photos should be separated from each other on the scanner bed or in the camera image 
by a few mm, and should not touch the edges of the scanned area if padding is not used. 
Increasing the threshold value may help to detect closely spaced photos. Most domestic flatbed 
scanners will only scan a region of A4 size (297 x 210 mm, or 11.7 x 8.5 inches) or slightly less, 
even though the glass area, or platen, is larger than this (300 mm x 224 mm in one case). Parts 
of photos outside this area will be truncated, but the truncated image will usually be detected. 
The flood-fill algorithm is generally more robust than rectangle detection. 
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Rectangle detection 
The rectangle detection algorithm converts the scanned image to greyscale and uses the 
SimpleShapeChecker class to detect individual photos. A threshold value can optionally be 
applied which sets all pixel values in the converted image to their maximum value. 
Rectangle detection performs better than flood-fill where the background between photos is 
not uniform. This can occur with photo album scans and images, where patterned backgrounds 
may be used or fading makes the edges lighter than the centre.  Using this threshold can allow 
edges to be detected where there is little contrast between the image and the background. This 
may occur with black-and-white prints. Reducing the threshold value increase the likelihood of 
detecting a photo, at the expense of accuracy in defining its boundary. If the prints have a white 
border, using a dark background for the photos is helpful for improving detection 
 

Avoiding truncation 
 If truncation is to be avoided, care should be taken to include all of the photos within the A4 
area, which is often marked beside the glass area. This limits the number of 6 x 4 inch (150 x 100 
mm) prints to two, if truncation is to be avoided. If truncation of the sides of images is 
acceptable, three images can be placed as shown below. Parts of the photos outside the red A4 
boundary will be truncated, but all three images will be automatically detected as the scanner 
places a white border around the scanned image. 
 
If existing scans are to be used where the photos touch the edges of the scan area, the Pad 
Image option in settings can be used to add a white border to the loaded image, which will 
improve detection. 
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Figure 5 Placement of three 6 x 4 inch prints on a A4 scanner. 

Scanner or Camera? 
Photo albums pose particular problems: they are frequently larger than A4 size and the pages 
will not fit onto an A4 scanner. If a part of a page is scanned, photos will be truncated and the 
fixed location in the centre of the shortest edge of the image will not identify the background 
correctly. The background location is defined by a circle (visible at the top of the loaded image 
in Figure 6). This can be dragged to a location between photos for best results from automatic 
photo detection. 

 
Photographing a number of photos may be more convenient than using a scanner. In this case, 
the camera should be directly above the photos, which should be placed on a plain background 
and illuminated with natural light if possible. Avoid including edges in the image.  Files from 
cameras are generally only suited to producing splits for computer devices, as few have an 
image size greater than 12 megapixels. This limitation can be minimised by only including one or 
two photos in each image. 
 
There are a lot of web pages and videos on the topic of digitising colour slides. A search for this 
term will reveal many of them.  The service is widely available professionally and there are also 
DIY methods, some involving dedicated hardware. ImageSplit is not necessary for this task, but 
the captioning facility of Caption Pro may be useful.  
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Image Loading and Photo Detection 
 
Once the scanner and resolution have been selected, clicking Scan (or using hotkey Alt-FS) in the 
screen shown in  Figure 1 or selecting the File->Scan option initiates scanning. 8, 24 or 48-bit 
depth scans can be processed. 8-bit greyscale scans are converted internally to 24-bit colour. 
Alternatively, files  can be loaded via the File->Open menu option. By default, automatic photo 
detection with the default flood-fill algorithm is applied once the image is loaded from a 
scanner or a file to give a display similar to that shown below: 

 
Figure 6 Screen after Detection of Photos 

The left-hand pane of the screen shows the loaded image with detected photos framed in red, 
and the right-hand Preview pane shows the de-skewed extracted photos.  Dragging the vertical 
splitter bar sideways increases or decreases the screen area of each pane. Dragging the red dot 
at the top of each frame sideways rotates the frame, and double-clicking on the red X in the 
centre deletes the frame, the associated preview in the right-hand pane and any file saved from 
the previews.  
 
If at least one split is created, the All Splits Preview box is enabled as shown above, allowing all 
splits to be saved via the Save button (or hotkey Alt-S), and their brightness, contrast and 
sharpness changed. Grey-scale splits can also be colourised using a web service by checking the 
Colourise box. If colourisation is the only function required, a single split can be created from 
the whole of the loaded image via the Add Split(s) menu item. 

Colourising 
Colourising black-and-white photos was once performed manually using painted-on dyes, but 
the process is now more commonly performed on digital images using artificial intelligence 
methods involving neural networks, with generally satisfactory results. 
 
Photo detection times will be much longer when colourisation is used, and an Internet 
connection is required. The longest dimension of colourised splits is limited to 800 pixels, 
making colourised images only suitable for display on electronic devices. Examples of raw and 
colourised splits are shown below. If higher resolution colourised images are required, there are 
a number of web and local applications available which can be found by searching for 
“Colorization applications” on your search engine of choice. Colourisation works best on images 
with “average” compositions – see here for a longer discussion of this topic. 

https://medium.com/towards-data-science/colorizing-images-with-a-convolutional-neural-network-3692d71956e2
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Figure 7 Examples of colourised (top) and grey-scale (bottom) splits 

The Size scrollbar varies the size of all the previews, which are re-arranged to maximise use of 
the right-hand pane. The number beside the each of the scrollbars  varies can be varied 
between 0 and 100, with a default value of 50. The Open button opens the Splits folder. 

 
Figure 8 All Splits Preview Box 

Individual split previews have additional buttons for rotation, flipping and full-size display in a 
new window. Splits can also be deleted via the 

 
 button. The file name for the split can also 

be specified. This name may be descriptive and can be applied as a visible caption after 
ImageSplit is closed via the Caption Pro Auto-split option. If the split comes from a loaded file, 
the default name is the name of the loaded file with a numeric suffix added and is saved in a 
folder called Splits within the folder containing the loaded image. Where the image comes from 
a scanner, the scan time is used as the file name to which suffixes are added and the file is saved 
in the folder specified in Settings. 
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Figure 9 Individual Split Preview elements. 

Splits  

Adding Splits Manually 
Where not all the photos present have been automatically detected, the Add Split(s) menu 
option can be used to add between 1 and 4 splits to the input image at fixed locations. If 2 or 3 
splits are added, they can be aligned in portrait or landscape mode, as selected by radio buttons 
ion the image below. There is also an option to create a single split containing the whole loaded 
image. This may be useful for colourisation. 

 
Figure 10 Add Splits Screen 
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Adjusting Splits 
Individual splits can be resized by dragging the sides of the split rectangle, rotated by dragging  
the red dot at the top sideways, moved by clicking and dragging anywhere inside the split and 
deleted by double-clicking on the red X in the centre. The cursor changes for each of these 
actions as shown below: 

 
Changes in the splits are immediately reflected in the de-skewed previews in the right-hand 
panel. 
 
All splits can be deleted by the Clear Splits top-level menu item. 
 

Sub-dividing Splits 
Splits can be sub-divided into a specified number of rows and columns with variable spacing 
between sub-splits  by right-clicking to show the following screen: 

 
If OK is selected the selected split is replaced by a grid of splits with the specified number of 
rows and columns and spacing between the sub-splits. The sub-split spacing is a percentage of 
the sub-split width and height with spacing set to zero. Cancel closes the form without 
performing the subdivision. Restore replaces a set of subdivided splits with the split before 
before subdivision, if subdivision has occurred. Restore is useful where the split orientation, 
position, row or column count is incorrect and the subdivision process needs to be repeated. 
 
If sub-dividing is used on an image containing multiple sub-images in a regular grid (such as a 
contact sheet as shown below), care must be taken to align the parent split so that the sub-
splits align correctly with the images: 



SetTags User Manual 

Commercial-in-Confidence 14 Aleka Consulting 
  www.alekaconsulting.com.au 

 
 



SetTags User Manual 

Commercial-in-Confidence 15 Aleka Consulting 
  www.alekaconsulting.com.au 

Settings Screen 
This screen is used to define the detection method, the save folder for splits, the Auto-split 
threshold, parameters for adding splits manually, whether detection is automatically applied on 
image loading and whether a sequential numeric prefix is added to split file names. 

 
Figure 11 Settings Screen with default Flood Fill detection method 

Add Numeric Prefix to Save File Name 
If the Add Numeric Prefix to Save File Name is checked, a numeric prefix is added to the file 
name shown in. The prefix is the number of files saved before the current save operation  
padded with two leading zeros. Use of this prefix allows sorting of the saved files by name in the 
order in which they were scanned. 

Split Rotation Sensitivity 
This parameter changes how much the split is rotated in response to movement of the rotation 
icon left or right. 

Pad Input File 
If checked, a white border is added to the loaded image. This may improve detection of 
individual photos where the photos touch the edges of the scanned area. 

Threshold (Flood-fill) 
The extent of the flood-fill operation on the edge-detected image is controlled by the Threshold 
parameter. Any pixel values which differ by less than threshold from the value of the 
background pixel (as defined by the circle shown in the main image), which are connected to 
the background are filled. Allowed values are between 2 and 150 with a default value of 20. The 
results of this changing the threshold on the intermediate processing bitmaps can be seen by 
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selecting either the After Floodfill or the Boundary radio button and clicking the Show button. 
Tapping enter after changing the threshold value  
 
Low threshold values may result in photos being merged, multiple splits created from the same 
photo, or non-rectangular splits. The figure below shows the results from different threshold 
values: 

 
Figure 12 Results of detection using different threshold values. Filled regions are shown in green and the filled 
region boundary in light blue 

If the threshold value is too low, there will be unfilled regions between the photos. If it is too 
high there will be large filled areas within the photo boundary, and the fill boundary will have 
large gaps in it. The threshold value acts to trade off detection ability and accuracy. 
 
The Boundary option for the processing bitmap shows the filled region boundary in white and 
other points in black as shown below for a threshold value of 20:  
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Optimum values for the threshold value will vary somewhat according to the nature of the 
photos and the background pixel selection. This can be varied by dragging the circle visible by 
default at the centre of the top or right-hand side of the image to another location between 
photos. If photos are persistently missed in auto-detection, splits can be added manually via the 
Add Split(s) menu on the main screen. 
 

Rectangle Detection 
The Rectangle Detection parameters are shown below: 

 
Figure 13 Rectangle detection parameters 

If checked, Use Threshold replaces all edge image values which exceed the Edge Threshold by 
the maximum value (255), which appears as white.  Min Width and Min Height specify the width 
and height of the smallest rectangle which will be detected as a percentage of the image width. 
If more than 4 equal size photos are to be detected, the value should be reduced from the 
default value of 15%.  The processed image can be displayed by clicking the Show Edge Image 
button. The effect of changing the Edge Threshold value is shown below: 
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Figure 14 Rectangle detection with Threshold of 25 

All photos have been detected using  a threshold value of 25, but the boundary of the lower left 
photo is incorrect and the lower and upper right boundaries are not rectangular. Note that the 
splits are always rectangular and made fit within the split region. 
 
The display using a threshold value of 50 is shown below: 

 
Figure 15 Rectangle detection with a threshold value of 50 

Using a threshold value of 50, only 3 photos are detected but their boundaries are much more 
accurate. 
 
If Use Threshold is unchecked, no photos are detected in the example shown and the edge 
image is as shown below: 
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Figure 16 Edge Image with no threshold 
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Loading from a File 
Files created by a scanner, or by a camera (such as are built into mobile phones) also be loaded 
via the File-> Open menu. Most bitmap formats are supported, including JPEG, BMP, PNG, TIFF 
and PNG.  

Importing Mobile Phone Photos 
Mobile phone photos can be imported via email or by connecting the phone to a PC USB socket 
with the lead normally used for charging. After entering a password to trust the computer (for 
an iPhone), the phone appears as a device in the This PC node. Opening this device and the 
contained DCIM folder eventually shows the photo storage folders. The most recent photos are 
contained in the highest numbered folder in DCIM and can be copied to any desired location. 

 
Most mobile phones have an image resolution of 8-12 megapixels. This means that the 
resolution of extracted images where there are more than 2 or 3 photos will only have sufficient 
resolution for device display. However, phones with higher resolution cameras (such as 
Unihertz) can produce images of similar resolution to a 600 dpi A4 scan, from which high-
resolution photos can be extracted. 

Saving Splits 
Once splits have been defined, and optionally rotated, flipped or adjusted for contrast, 
brightness or sharpness, they can be saved into the Save folder in JPEG format. The name of the 
file used for the split can also be changed and may be applied as a caption displayed in a bar 
beneath the original image within Caption Pro by using the file name as an  auto-caption source. 
Any characters not allowed in Windows file names (such as ?, = or \) are changed to 
underscores (_). If the image has been obtained from a file, the default save folder is located in 
the folder containing the file, with the name ‘Splits’. If the image is loaded from a scanner, the 
splits are saved in the specified folder rather than a Splits subfolder.  

Adding Captions to Saved Splits 
 
Once splits have been saved and ImageSplit has been closed, Caption Pro displays the files in the 
Save folder in Modified date order. Two-part captions can then be added to these files if 
desired, either overwriting the saved files or creating a new file as specified in the Options 
screen. The same caption can be applied to all saved files using the Batch options of Caption 
Pro. Descriptive file names can also be used an auto-caption source. 
 
As all files in or below the save folder, are loaded into Caption Pro, it may be the case that files 
are present which have already been captioned. Files with captions can be moved to another 
folder via the Caption Pro Edit->Copy/Move Captioned option. 
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Frequently Asked Questions 

1. Automatically detected splits do not correspond to photo 
boundaries 

This problem can manifest as either duplicated or skewed splits as shown below, where 5 splits 
have been generated from 3 photos 

 
In this case the problem arises through incorrect detection of the background, caused by parts 
of a photo being outside the scanned area. The background location circle at the centre top is 
not outside the photo boundary. Dragging it to a position outside any of the photos gives the 
expected result. Duplicated splits can also be deleted. 
 
If a non-white background is used and photos are touching the edge of the scanner, the entire 
scan will be detected as a split as shown below: 

 
This happens because a small amount of white padding is often applied to the scanner output 
and the default background colour position is within the white padding, so the entire scan is 
detected as a single image. Moving the background location to within the non-white 
background results in no photos being detected: 
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To fix the problem, photos should be moved away from the scanner edges so a few mm of 
background completely surrounds each of them, and the background definition point should be 
moved into the background area: 

 
 
Where photos have a patterned and non-uniform background, as shown below, none or only 
some photos may be detected. After moving the background pixel to the centre of the image, 
only one of the 4 photos is detected with the default threshold value of 20 as shown below. No 
threshold value successfully detects all of the photos.  In this case, the rectangle detection 
algorithm should be tried, or splits should be added manually. If automatic detection is 
required, other products such as ScanSpeeder or AutoSplitter may be more successul. 

https://scanspeeder.com/
https://autosplitter.com/
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Where photos are touching each other on the scanner (as shown below left ), there are no 
rectangular boundaries of the filled region around the touching photos as shown below (right) . 
This will resukt in the touching photos not being detected. 

  

2. Cannot connect to scanner 
Ensure that the scanner is switched on and connected to the PC, either via a USB port or a 
wireless connection. Then check that the scanner works using existing scanner software. If the 
scanner works with existing scan software but not with ImageSplit, then use existing software to 
save a scan as a 24-or 48-bit colour file and load this into ImageSplit. 

3. How I can I best use ImageSplit for a large number of photos? 
If you wish to digitise a large number of paper photos and add visible captions to them, the 
easiest way to do this is to use the file name as the caption, and then use the Auto-caption 
facility of Caption Pro to insert the file name as text within the images as a single operation. 
However, the following characters are not allowed in file names, and thus cannot be used in 
captions applied in this way 
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If captions are added manually in Caption Pro, any character can be used (including Asian 
languages). 

4. ImageSplit crashes. How can I get support? 
ImageSplit creates a  log file and writes to it at various stages in its operation. The log file is 
stored in the user’s My Documents folder with the name ImageSplitLog.txt. Email this file to 
support@alekaconsulting.com, if possible accompanied by a screenshot of the application 
before it crashed. 

mailto:support@alekaconsulting.com
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Examples of splitting with different algorithms and parameters 

24 bit colour scan, 600 dpi, rectangle detection 

 
No difference from changing threshold from 10 to 15, 1 image missed at 20. 

24 bit colour scan, 600 dpi, floodfill detection 
 

 
Threshold of 10 detects all photos but adds a non-boundary split to one. Other values miss one 
of the photos.  
 


