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Document Purpose 
This document describes the functionality of SetTags and how to use it. Installation is described 
in the document Set Tags Installation. 

Overview 
 SetTags is an application for:  
 

1. Managing a list of applicable tags and descriptions. For Workgroup versions, only a Workgroup 
Master user can edit tags. 

2. Loading and viewing single or multiple item (file, folder, URL or mail message) selections, with 
a preview of item content. 

3. Tagging single files and folders by including tag names in the file or folder name, and creating 
a shortcut in a facet folder sub-folder with the name of the tag with the shortcut defined using 
a drive letter, or a UNC path. 

4. Tagging single or multiple Outlook email messages from with Outlook. Tags are stored as mail 
categories. 

5. Tagging single or multiple URLs. 
6. Applying the same tag to multiple files, or files in a folder, selected by either by browsing  the 

filesystem or from files loaded into SetTags.  
7. Applying different tags to a multi-file selection on the basis of a view of the file content using a 

slideshow window 
8. Automatically generating tags from rule based on file name, path name or content. 
9. Viewing items  with any tag or combination of tags as a grid list within SetTags 
10. Creating a Zip archive of tagged files for export to users not running  SetTags 

 
When SetTags applies a tag (or tags) to a file or folder, it adds the tag string to the file or folder 
name and creates a shortcut to the file in a sub-folder of the Facet folder (see page 45 for more 
details). The shortcut can use a drive letter or a mapped UNC path to refer to its target. The 
shortcut name is the name of the original file. SetTags accesses tagged files via the targets of 
shortcuts contained in the Facet folder sub-folders. Shortcuts will update automatically if the 
target file is moved or renamed. Deleting a tag from a file removes the shortcut pointing to the 
file in the Facet folder sub-folder, or the file itself and removes the tag from the file name in its 
original location. Tags for Outlook emails are stored in the local database and are shown in 
Outlook by defining Categories with the tag names and applying these to tagged files so they are 
visible in Outlook. Tags for URLs are stored in the network database. 
 
Tagging of files and folders can be performed by selecting multiple files or single folders in 
Windows Explorer and sending them to SetTags via a right-click on the selection, or by dragging 
them into the application. Files and folders can also be selected from within the SetTags 
application. Tags then can then be applied to all the loaded data or selection from it. Tags can 
be added to individual files by dragging from the tag list to a file list. Emails can be tagged from 
within Outlook after installation of the Outlook Add-in OutlookTag. 
 
Most tag operations can be performed by right-clicking in the Tags box to show a context menu. 
View options access this functionality via buttons in the Input Data Actions and View boxes. 
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SetTags can operate in multi-user mode using either a shared network drive or cloud storage. 
User access to tags and items containing a particular tag, and the management of the tag list, 
can be controlled. 

 
SetTags requires Windows 7 or newer (64-bit operating system) with .Net 4.6.1 Framework, and 
the Desktop application SetTags.exe is a 32-bit application.  

Usage Scenarios 

Multi-User Operation 
 
SetTags can be used with multiple users accessing the same group of documents in two modes. 
 
Cloud mode operates only when files and folders are shared between users by a cloud service 
such as OneDrive, Google Drive or Dropbox. There is no central management of tags by default 
– any user can delete, add to or edit tags. When this happens, other users are notified and need 
to restart SetTags to see the changed tags.  
 
Workgroup operation is discussed in more detail on page 52. 

Cloud Operation 
Most cloud storage providers offer the option of storing cloud files in a local folder, which is 
then synchronised with a folder stored on the remote cloud server. Folders can be shared by the 
cloud folder owner via a Web page, using the process described here for Microsoft OneDrive. 
 
In order to use Cloud functionality, the facet folder and all files and folders to be tagged must be 
within a local folder synchronised with cloud storage. A warning message is shown if files being 
tagged are not within the specified cloud folder. 
   
As SetTags functionality requires a particular facet folder structure and the implementation of 
Windows shortcuts, selective sharing of files with particular tags on any platform is not possible 
via OneDrive. If folders containing input files and the facet folder are stored in the OneDrive 
local folder and all OneDrive access is from Windows devices, SetTags can be used by multiple 
users, and changes made to any tags will be synchronised to all other SetTags user. 
 
If OneDrive is used from a non-Windows device, any folders containing tagged files can be 
shared with specific users via the email address which they use for OneDrive authentication. 
The facet folder should not be shared, as the shortcuts contained in it will not work. Tagged files 
can then be located using Search functionality on the device. Any changes to the content of 
these files will then be synchronised back to all other OneDrive users with access to this folder. 
All OneDrive users will be notified of any changes to file content. The tag name (included in the 
file name) should not be changed. 
 
If access to files with selected tags needs to be restricted in a OneDrive environment, the only 
way to achieve this is to restrict the sharing of folders containing input files with selected tags. 
The flexibility of access control for files and folders provided by the Windows filesystem is not 
available for cloud storage. 
 
Dropbox allows access control of folders with the free version, but all users must have Dropbox 
installed, whereas OneDrive is built into Windows 10. As each user accesses their own local tag 
database, any user can edit the tag list in the local cloud folder unless this permission is 

https://support.office.com/en-us/article/share-onedrive-files-and-folders-9fcc2f7d-de0c-4cec-93b0-a82024800c07
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restricted. If the tag list is changed by any user, other users will be warned to restart SetTags in 
order to use the updated tag list. 
 

Scanned Documents 
Applying some kind of descriptive metadata to scanned documents is essential if the scanned 
documents are to be accessed effectively. Optical character recognition (OCR) may be applied to 
create searchable content in the scanned files (usually in PDF format) but PDF content is not yet 
routinely indexed on Windows filesystems. The quality of the OCR may also be poor on 
documents with coloured backgrounds, typewriter fonts or low-contrast printing. Descriptive 
file and folder names are frequently used to allow systematic access to scanned documents, but 
these have limited descriptive capacity. Documents frequently have multiple attributes which 
are of interest, which can be easily added as tags. 
 
Scanning of paper documents is frequently performed as a service, where the scanned 
documents are sent to an external agency which may not have software required to access 
documents via their tags. SetTags export functionality creates a folder tree from the tag 
structure with folders populated with documents having a particular tag. This allows recipients 
of the exported documents to utilise the tag structure without any additional software or 
training, and also to add tagged documents to their own SetTags instances if required. 

Organisational Document Management 
Organisations of all sizes have problems retrieving documents relating to particular issues. In 
the not-for-profit area, high staff turnover and financial stringencies compound the problem. 
While free document management systems exist, new staff are most comfortable working with 
systems they are familiar with. SetTags simple interface and close integration with Microsoft 
Windows ensures that new staff can quickly become familiar with application of tags to 
documents and retrieval on the basis of tags. 
 
If a shared network drive is used, the Workgroup version provides access control for tagged 
documents. For cloud-based sharing, the Cloud version provides this functionality. 
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Installation, Running and Uninstallation 
The self-extracting installer SetTags_nn.exe (where nn is the version number) should be 
downloaded from the Aleka Consulting web site. Double-click on the downloaded file to install 
the program. Select the option to launch the program after installation as this will create the 
option to send files to SetTags via a  right-click. 
The program can be found in the Aleka Consulting->SetTags folder in “All Programs” as shown 
below: 

 
 
If desired the program can be pinned to the Start menu by right-clicking on the program and 
selecting Pin to Start Menu. 

Tagging Emails using OutlookTag 
 
If tagging of emails from Outlook is required, the following steps should be followed: 
 
1) Download the OutlookTag.zip file and extract its contents into a convenient folder. 
2)  If Outlook is running it, close it and check that Outlook.exe is not running by showing the 

Processes tab of Task Manager or the Details Tab in Windows 10.  Select “End Process” after 
right-clicking  on Outlook.exe in the Task Manager list 

3) Then click on the extracted file OutlookTag.application. This  will install the OutlookTag  
Add-In. The installation process should complete with the message “Registration 
successful”.  

4) Restart Outlook. The start screen should indicate when the different Add-Ins are loaded. 
After loading OutlookTags the main screen and message screen should  appear as shown  in 
the section Loading Items from Outlook on page 24. 
  

 SetTags must be installed and run before OutlookTag is installed. Installation of the Add-In 
before SetTags Desktop is installed and run once will result in a warning message and the Add-In 
buttons being disabled. 
 
SetTags and OutlookTag may be uninstalled from the Control Panel->Programs and Features list 
in the same way as any other application. 

Administrator and non-Administrator Users 
Installing SetTags on a machine from a user account with Administrator privileges will make the 
program accessible to all users of the machine. However, unless the program is run from an 
Administrator account, or as an Administrator, no shortcuts will be created in the default facet 
folder location (C:\Users\<UserName>\AppData\Roaming\SetTags\Facets). A warning message 
will appear if the default Facet Folder location is used with a non-Admin account. A different 
facet folder location should be specified in this case.  

http://captionpro.com.au:443/AlekaConsulting/index.php/settags-2/
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Desktop Operation 

First Run 
After installation, a Demo Cloud license is automatically created when SetTags is run (either by 
clicking the Program entry or by sending selected files to SetTags via right-click Send->SetTags), 
which expires 30 days after installation or when 100 items have been tagged. A Demo license 
can only be used once. Contact Aleka Consulting if a second Demo license is required. 
 
When SetTags is first run with a Demo Cloud license, the user is prompted to ask if they wish to 
tag files in a local folder synchronised with cloud storage, as shown below: 

 
If the answer is yes, the following screen is shown. The screen is always shown for a non-demo 
Cloud license. 

 
Figure 1 Selecting local cloud storage folder 

This screen allows the local folder synchronised with cloud storage to be selected. If the name 
of the folder is not shown, it can be selected via the Browse button from the user directory. A 
facet folder is created in the selected folder. 
 
If the answer is No, the screen shown in Figure 1 is not shown and the License type becomes 
Desktop. Demo licenses may be selected as  either Cloud or Desktop via the Options screen as 
shown below: 
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Figure 2 Selecting the Demo License Type 

The Demo License options are disabled for non-Demo licenses. 

 

Licensing 
If a license key has to be installed for SetTags, or the database used by it has to be changed, this 
is done by clicking on the License top level menu to show the following screen: 

 
Figure 3 Licensing screen 

Any license key received is entered in the License Key text box and the Apply button clicked. 
License details are then shown. When a license expires, only the License top-level menu item 
remains accessible to allow entry of a new license code. 
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For multiple users, the maximum number of users over the last 24 hours is defined the Max 
Users box. The current number of users over the period is shown to the right of it. If the 
maximum number is exceeded, SetTags becomes unlicensed and non-operational until the 
number of users over the previous 24 hours has dropped below the limit. 
 
The local database connection is set by default on installation, but can be redefined if required. 
The Network Database connection is the same as the local database connection for Demo and 
Desktop licenses. It may be different for Workgroup licenses. Workgroup operation is described 
on page 50.  

Start Screen 
Once a valid license has been obtained, the SetTags main screen appears, with the following 
default appearance: 

 
Figure 4 Default SetTags main screen on loading 

Tags may be ordered by Name, Description or by the oldest modified date of files with that tag 
using the Order By combo box. The Clear All button clears all selected tags. The number of days 
before license expiry is shown below the tag list. More information on each enabled control can 
be obtained by hovering the mouse over the control or clicking the Information button  

beside it. 

View Options 
The Input Data Actions and View boxes may be shown or hidden using the View->View Box and 
View->Input Data Box options. The main functionality provided by the buttons in each box can 
be accessed by right-clicking in the Tags box. 

 
Figure 5 Other view options showing Input Data Actions  (left) or Input Data Actions and View boxes (right) 
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If a tag is selected and one or more item loaded, the “No Tags Selected” region above   the tag 
grid turns white and indicates that dragging tags onto a file selected from the grid is enabled. 
The grid shows the input item properties. Different icons in the Type column are shown for files, 
folders, mail messages and URLs. 

 
Figure 6 Drag box above tag list enabled after tag selection and input file loading. 
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Menu Items 
Menu and sub-menu items are shown below: 

 

  
Menu Item Description 

File->Tag File(s).. Loads single or multiple files. See Loading . 

File-> Tag File(s) in Folder Loads files in or below folder 

File-> Tag Folder Loads single folder 

File-> Tag Web Page(s) Loads URLs of Web pages by pasting 

File->Options.. Sets operation parameters. See Options Screen. 

File->Export.. Exports tagged files. See Exporting Tagged Files. 

File->Exit Closes SetTags. 

Edit->Facet Folder Shows/sets Facet folder. See Facet Folders. 

Edit->Filter Sets filter for including or excluding files to tag. See Tag Filter. 

Edit->Create Facets Create Facet folder from tags in file names. See Creating the Facet 
Folder. 

Edit-> Delete All Tags Delete all tags from all tagged files or input selection. See Delete 
Operations. 

View->Errors Show errors in operation. See Errors. 

View->View Box Show or hide View box 

View-> Input Data Box Show or hide Input Data Actions Box 

License Show or set License and databases. See Licensing. 

Auto-Tag Rules Define rules for auto-tagging 
Help->Help Show help 

Help->Manual View manual as PDF file 

Help->FAQ Show Frequently Asked Questions as PDF file. 

Help-> Support Prepare and optionally mail support data. 

Help->About Version information for SetTags. 

 

Adding and Editing Tags 
A number of pre-defined tags are included in the initial database. These can be deleted or 
renamed as required (except for _Auto-Time). 
 

Tag Name Description 

Company Confidential Confidentiality 

Public Confidentiality 

To Do Status 

Project1 Projects 

Project2 Projects 

Templates Communications 

Logos Communications 

HR Organisation 
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Finance Organisation 

_Auto-Time Automatically generated from metadata 

 

Auto-Time Tag 
If _Auto-time is checked, a tag is generated from the file Modified date in the form YYYY –MM 
(MMM) (eg 2014-1 (Jan)) and applied automatically to the file. Files with the same month of 
modification are assigned the same tag.  If the Move Operation mode is chosen, the files can be 
moved into folders with names representing the year and month of modification. This format 
means that folders sorted by name will be in date order as shown below: 

 
Figure 7 Date ordering of folders after Auto-Time tag generation 

Files can then be selected from these folders for subject-based tagging. 

Auto-Tag Rules 
Auto-Tag rules can be used to set tags on the basis of text found in the file name, file path or 
content. The rules are specified by clicking on the Auto-Tag Rules menu item to show the 
following screen. A rule contains four parts as specified in the different colour boxes. 

 
The first step is to define a name for the rule by typing into the text box below the AutoTag Rule 
Name box and clicking Add New: 
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The Rule Description box then reports that a domain for the rule has not been defined. The 
available domains are the file name, the file path and the text content, which can be selected 
from the check boxes below “Apply AutoTag Rule On Domain”. If the file does not contain any 
text, the rule will never be satisfied. 

 
The Rule Description box then prompts for the tag to be added when the rule is satisfied. This 
can be entered from the dropdown on the right, and a new tag can be added if required. 

 
The Rule Description box then prompts for the addition of a word, phrase or regular expression 
(Regex) to complete the rule. These should entered in the white text box to the left of the Edit 
button, and Add New clicked. The entered text then appear in the list box above the text box, 
and the Rule Desciption shows the complete rule with components shown in bold as below: 

 
Additional words, phrases or regular expressions can be added by repeating this process: 
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If any of the words or phrases entered appear in the selected domain (or domains), or if the 
regex is matched, the selected tag is applied. 
 
If a regular expression has been entered, the  Regex checkbox to the left of the expression 
should be checked. 
 
Once the Rule Description contains elements shown in bold, the rule may be saved using the 
Save button in the bottom right-hand corner of the screen. Clicking cancel (or closing the form) 
discards all changes made to the rules since the screen opened. If the Save button is clicked 
without all four components of the rule being satisfied, a warning message is shown and the 
incomplete rule is not saved. 
 
Checking the  Apply check box applies the rule when the Auto-Tag option is selected from the 
main screen. 
 
If more than one rule is defined, rules can be selected for editing from the dropdown in the Rule 
Name Section 

Regular Expressions (Regexes) 
Regular expressions (or regexes) are a sequence of characters that define a very flexible search 
pattern rather than the simple keyword search used in most search engines. The syntax can be 
extremely complex, but some of the most common requirements are to: 

 match an occurrence of a search pattern at the start or end of a string 

 match the negation of string (satisfy a rule when a string does not appear) 

 match a range of letters or numbers 
 

There are number of web sites offering regex information, tutorials and expression checkers: 
 Wikipedia – information 
Regex101 – expression checker 
Expresso –Windows Desktop expression checker and tutorial 
Regular-Expressions.info - tutorial  

https://en.wikipedia.org/wiki/Regular_expression
https://regex101.com/
https://www.codeproject.com/Articles/9099/The-30-Minute-Regex-Tutorial
ttps://www.regular-expressions.info/tutorial.html
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User Tags 
A set of tags which can be applied to items can be pre-defined before any items are processed, 
or tags can be defined on the fly after a group of items has been selected. The Tag Management 
screen is accessed via Add/Edit below the tag list: 

 
The tag management screen is as shown below: 

 
Figure 8 Tag Management Screen 

The _Auto-Time tag is always present and cannot be deleted. Tags can be added by typing a tag 
name (and optionally Description in the Desc box) into the box to the left of and below the Add 
button. Multiple tags can be added by pasting a list of tag names and descriptions from the 
clipboard using the Paste button. The names are separated by a new line and the name and 
description are separated by a tab character. Any existing tags are replaced. New tags can also 
be updated from a text file containing the same data (and the shortcut mode being used) via the 
Load button. Files containing all tags and descriptions for a particular set of facets are shown in 
the facet folder with the name TagNameDesc.txt. 
 
 Tag names cannot include commas or any characters not allowed in Windows file or folder 
names as follows: 
 
    < (less than) 
    > (greater than) 
    : (colon) 
    " (double quote) 
    / (forward slash) 
    \ (backslash) 
    | (vertical bar or pipe) 
    ? (question mark) 
    * (asterisk) 
     Tab  
 
The strings !TS! and !AT! are also reserved and cannot be used. 
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If you need to copy the list of tags and descriptions, these can be transferred to the Clipboard by 
clicking the Copy to Clipboard button. A list of the tags (and the Shortcut Mode) is saved in the 
Facet folder in the file TagNameDesc.txt. This is updated whenever a tag is changed. 
Once tags and descriptions are added, tags and/or descriptions can be changed or deleted by 
selecting them and using the appropriate buttons. The Select All and Clear All buttons can be 
used to select or unselect all entries. 

 
Figure 9 Renaming and deleting tags/descriptions 

 
When deleting or renaming tags, the option to only change tags in the tag list or to change the 
tags already applied to items is shown: 

 
Figure 10 Option to delete files from list only or from list and files 
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On closing the User Tag screen (by clicking on the X at the top right of the screen) and returning 
the main screen, the tags are available for selection and application. The tag descriptions appear 
when hovering over the tags: 

                   
Figure 11 Main screen after tag definition (left) and tag description display when hovering over tag (right) 
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Loading Items 
Files and folders can be loaded either from within the application or from Explorer by right-
clicking and selecting Send To-> SetTags. URLs can be loaded from within the application. 

Loading From Application 
Files or files in or below a folder to be processed can be selected from the File->Tag File(s).. and 
File->Tag File(s) in Folder.. menu options. If a single file is loaded, any tags applied are shown in 
the Tags box below the input file as shown below: 

 
If multiple files are loaded, all the files are displayed in the grid as input data: 

 
 
The icon in the Type column indicates whether the item is a file (blue file icon), a folder (yellow 
folder icon), a mail message (black mail icon), or  URL (black globe icon). 
 
If a folder is loaded via Tag File(s) in Folder, files in the folder, or files in the folder and sub-
folders may be displayed as shown below: 

 
If the option selected displays a very large number of files, the loading process may take some 
time. The number of files loaded is shown below the tag list. Loading can be terminated by 
clicking the Stop Loading button, which is displayed during loading.  
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Figure 12  Loading from a folder with a large number of files 

After selecting Yes or No, the files are displayed in the input data grid. Grid content can be 
sorted by any of the displayed columns by clicking in the column header. Grid column widths 
can be changed by dragging the column boundary. 
 
Once input files are displayed in the grid, tags may be added or removed or the display filtered 
as described in following sections. 

Loading Folders 
Single folders may be loaded via the File->Tag Folder option. Loaded folders are shown with a 
yellow folder icon as shown below. Folder are processed in the same way as file, with a tag 
string being added to the folder name. 

 
Figure 13 Folder  loaded for tagging 

Loading URLs 
URLs can be loaded by pasting the URL of a web page into the screen shown by selecting File-
>Tag Web Page(s): 

 
Figure 14 Screen for loading URLs of Web pages 

The URL of a web page can be copied to the Clipboard  as shown below  
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Figure 15 Copying URLs from Firefox (left) via menu option and from Chrome (right) via select/copy 

If the browser screen and the SetTags screen are both visible, URLs can also be loaded by 

dragging the icon at the left of the address bar onto the white Input File(s) box. 

 
Loaded URLs appear as shown below 

 
Figure 16 Loaded URLS 

 

Loading Files and Folder Content from Explorer 
Single or multiple files, or the file content of single folders can be loaded by from Windows 
Explorer by selecting the group of files or a single folder for tag addition or removal and 
dragging them onto the white Input Files/Folder box in the main screen. 

 
 
Items can also be loaded by right-clicking and selecting Send To as shown below: 

 
Figure 17 Example of item selection by right-clicking on Windows Explorer selection 

 
The main SetTags screen then shows whether a single file or folder, or multiple files have been 
selected. 
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Loading Items from Outlook 
After installing the OutlookTag Add-In, Mail messages and Contacts can be tagged.  

Mail Messages 
Mail messages can be loaded from the main Outlook window via the Tag Selected button in 
SetTags tabs in the ribbon as shown below. 

 
Figure 18 Loading single or multiple email messages from Outlook main window 

Any messages selected appear in SetTags as shown below. The date is the date on which the 
email was sent. 

 
Figure 19 Mail messages loaded into SetTags from Outlook 

 
Single messages can also be loaded via Tag Message button in the Message window 

 
Figure 20 Loading single email messages from Outlook Message window 

Clicking on any mail message displays its text content as a preview: 
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After tagging, the tags appear in the Ext/Mail Tags column: 
 

 
If the messages are viewed in Outlook after tagging, the tags appear as Categories: 

 
 These tags can be selected when searching to display tagged emails within Outlook: 

 

Contacts 
Contacts can be tagged in the same way as Mail messages. After selecting Contacts rather than 
Mail in the left-hand Outlook pane, contacts are shown in the default Business Card view: 

 
Tags can be added by selecting the SetTags menu item to show the SetTags ribbon. Individual 
Contacts can be selected for tagging by clicking on them. The top bar turns orange when a 
Contact is selected as shown below.  
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Clicking Tag Selected then launches SetTags with the selected Contact (or Contacts) as input 
items as shown below. The Contact email address is shown in the 3rd column. 

 
Clicking on the items shows some of the contact information in the preview area 

 
The Contact  can then be tagged in the same way as for Mail messages. The tag applied is shown 
in the 4th column: 

 
Within Outlook, the applied tags are shown as Categories. These are visible in contacts in the 
Contact input data screen, shown as below by clicking on the Business Card Icon: 

 



SetTags User Manual 

Commercial-in-Confidence 27 Aleka Consulting 
  www.alekaconsulting.com.au 

They can also be shown in the List view for Contacts: 
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Clicking on the Business Card icon opens the Contact editing screen: 

 

Adding Descriptions to Items 
Text descriptions can be added to items to provide more information about them. Descriptions 
are edited by clicking in the yellow Description column to show the following screen: 

 
Figure 21 Description Addition screen 

Clicking OK adds the description text to the main grid as shown below: 

 
 Descriptions are particuarly useful for the URLs where content may bear little relationship to 
the URL text. 
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Processing of Items 
Processing may be the addition or deletion of selected tags, the deletion of all tags or the 
population of a facet folder (see page 45). The Desktop license only supports tagging of files and 
creation of a facet folder on local drives. Removable USB drives and USB drives are also 
accessible with a Desktop license, but network locations (shared drives) require a Workgroup 
license. 
 
The File->Tag File(s) menu allows selection of one or more files from a selected folder: 

 
Figure 22 Default file selection screen 

The default folder selection is the C: directory. Once files are selected, the default on re-opening 
is the folder containing the selected file (or files). If a single file is selected and Open clicked, the 
file path is shown on the main screen: 

 
Figure 23 Main screen after single file selection 

If a file to which tags have already been applied is selected, these tags are shown in the ‘Tags for 
file(s)/folder box’: 

 
Figure 24 Main screen after selection of already tagged file 
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If multiple files are selected the main screen indicates this: 

 
Figure 25 Main screen after multiple file selection 

Note that the Stop button appears for multiple file processing. This is enabled after Add 
Selected or Delete Selected is clicked. Clicking it stops processing Single folders can be selected 
using the File-> Open Folder.. option. This brings the up the following screen by default: 

 
Figure 26 Default folder selection screen 

A folder containing files to be processed can then be selected via the Tag File(s) in Folder.. menu 
item. If such a folder is selected, the main screen shows the folder path as follows: 

 
Figure 27 Main screen showing folder path 

This path is persisted for subsequent folder selections. 

Processing of Mail Messages 
When tags are applied to mail messages, the tags are shown in the FileExt/Mail Tags column as 
shown below: 

 
Figure 28 Example of display of tags, for files, folders and mail messages 
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Tag Filter 
If multiple files are selected, for example by selecting a folder, it may be that some files should 
be excluded from the tagging process. One reason is that file names may be used internally by 
an application and the addition of the tag to the file name may cause the application to fail. The 
filter is accessed by clicking Edit->Filter to show the following screen: 

 
 
Filters are defined as Regex expressions, and Regex documentation should be consulted to 
determine how to achieve the desired result. 
 
System and hidden files, and Office temporary files starting with ~ or Macintosh files starting 
with . are always excluded. Other file types which may be accessed on the basis of their file 
names (such as code files) should also be excluded. 
 
The Apply checkbox determines whether any filtering is applied when files are processed. Files 
not meeting the filter criteria are not shown in the grid display. Files rejected by the filter are 
listed as skipped in the run reports. The default setting for Filter Mode is Exclude, where the 
filter excludes files whose full path match a Regular Expression (Regex).  The Include Filter Mode 
setting includes only files whose full path matches a Regex, depending on the Filter Mode 
setting. Files with System or Hidden attributes are not tagged if any filter is applied. The default 
settings for the Exclude filter exclude file names with end in .db or .ini. The default settings for 
the Include filter include Office  files and common image and video formats. If these values are 
edited, the new Regex can be tested by clicking the Test button beside each string and stored by 
clicking the Store button. 

 
Excel spreadsheets containing links to other files may have the links broken the if the name of 
the link target file is changed, as the lin is stored as a relative path. If  Excel spreadsheets 
containing links are to be tagged, then links should be updated after tagging. 

Displaying Tagged and Untagged Items 
When items are loaded and at least one tag is selected from the list, controls in the View box 
are enabled as shown below. If no tags are selected only the loaded files are displayed. Clicking 
on the Show Tagged button shows all the files to which the user has access which have the 
selected tag or combination of tags. Note that these are not necessarily included in the loaded 
input files.  
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If more than one tag is selected, they are combined as AND or OR according to the Tag 
Conjunction setting. The loaded files can be redisplayed by clicking the Input Data button. 

 
Figure 29 Display of files with selected tags Tag3 and Tag4 

Clicking on the All Tagged button shows all files with any tag which are included in the loaded 
files. Note that the grid heading changes to All Tagged in this case. 

 
Figure 30 Display of all tagged files included in loaded files 

In the above example only a single tagged file is loaded. 

All Tagged and Not Tagged Display 
If  multiple files or folder contents are loaded, the All Tagged and Not Tagged buttons display 
complements of set of loaded files. The figure below shows results with a folder containing 18 
files, 12 of which are tagged. 
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Figure 31 Display of all loaded files(Top L),  all tagged files (Top R), untagged files (Bottom L) 

All of the view options can be accessed by right-clicking in the tag list box to bring up the 
context menu shown below. This option can be used if the View Box and Input Data box are 
hidden. 

 
Figure 32 Context menu for display and processing options 
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Viewing Items Shown in Grid 
Clicking on any row in the grid displays a preview of the item below the grid, and right-clicking 
or double-clicking opens the file with the selected Windows application for that file type in a 
new window as shown below. Folders are opened with File/Windows Explorer and mail items 
with Outlook. 

 
Figure 33 Displaying Files from the grid as a preview by a click (left) or using the associated application by a shift-
click (right) 

Some file types (such as Outlook msg files) cannot be displayed in preview, but can be opened 
by Ctrl-clicking. 
 
The first 8000 characters of Web page text content is displayed as a preview for URL items. This 
content may not be available for some URLS due to security issues. A warning message is 
displayed in this case. Text content may also be missing if the web page does not support 
particular browser versions. The absence of text content does not prevent the URL from being 
tagged. 
 
The up and down arrows on the keypad move the row displayed up or down. 
 

Adding to or Removing Tags from Selection of Items Shown in Grid 

Multiple Items Selection 
When one or more tags is selected, and items are shown in the grid, selected tags can be added 
or removed  from any items selected via the Add Tag(s) and Delete Tag(s) buttons, which are 
then enabled. Multiple items can be selected by clicking on a row and then shift-clicking on a 
different row. All rows in between will then be selected. Rows can be added individually to the 
selection by ctrl-clicking on the new row. 

 
Figure 34 Multiple Row Selection from Grid 

Clicking Add Tag(s)  in the Selected Files box above the grid requests confirmation: 
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If the addition is confirmed, tags are added to the selected items. If tags already exist in any of 
the selected files, the option to replace or append can be chosen. The display view then changes 
to Tagged Files: 

 
Figure 35 Display after Addition of Tags from Untagged Files Screen 

To delete tags from items, select the items from which the tags are to be deleted, and the tag(s) 
to delete as shown below: 

 
Figure 36 Files Before Deletion of Tag 3a from two selected file 

The expected result is that the tag “Tag 3a” is removed from the file called example.m4p before 
any tag was applied, as shown below. The other selected file did not contain the selected tag 
and is unchanged. 

 



SetTags User Manual 

Commercial-in-Confidence 36 Aleka Consulting 
  www.alekaconsulting.com.au 

Adding Tags To a Single File Selection using Preview 
Where tags are to be applied to files on the basis of the file preview, this can be achieved by 
clicking the file row in the grid to show the preview, and  then dragging from the  tag selection 
box above the tag list onto the file shown in the grid as shown below. This has the same effect 
as selecting the file to be tagged and clicking Add Tag(s) in the Selected Files box above the grid. 
It may be helpful to hide the Input Data Actions and View boxes from the View menu in this 
case: 

 
Figure 37 Adding Tags by Dragging  to a Single File on the Basis of Preview 

Adding Tags to Single File Selection from Slideshow 
Slideshow mode also adds tag to a single file. The preview  is shown over the full screen for 
Office, text and media files. After loading single or multiple files, the Add from Slideshow button 
in the Actions box is enabled. Clicking this button displays all loaded file as shown in the screen 
below. A similar screen is shown for any files displayed in the grid by clicking the Tagged 
Slideshow button in the View Grid. The screen can be used to add or remove tags as well as 
display files sequentially. 

 
Figure 38 Slideshow screen showing video 
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Images can also be shown visually, as well as  the first page of Office and PDF documents.  The 
Edit button allows images to be edited using the Windows default application. Videos must be 
stopped using the blue controls directly below the video before the a different slide can be 

viewed using the navigation buttons at the bottom left.  

 
Tags can added (and removed) individually via the combo box. New tags can also be defined. 
Only existing  tags can be removed. 

 
Figure 39 Applying tags(Left) and removing tags(right) from within slideshow 

 
For files type other than media, a file preview is shown: 

 
Figure 40 Slideshow view of non-media file 

This view displays the content of file types supported by the Preview control (including Office 
files).  Even if the file type is does not have its content shown, it can  be viewed via the View 
button, which launches a read-only copy of the selected file with the default application. 
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File metadata may be viewed by clicking the Metadata menu item at the top LHS of the screen: 

 
Figure 41 File Metadata 

The general group of metadata fields is shown first, then the metadata field name and finally 
the value. 
 
 
The list of selected files may be traversed using the left ( )  and right ( ) arrow buttons in  

the lower left corner of the screen. If the cursor is left on either of these buttons the list may be 

traversed using the left and right arrow keys on the keyboard. The button moves back to the 

first item in the list and 
  

 to the end. Clicking the slideshow button  moves automatically 

through the list, displaying each slide for the time interval selected by selecting  the slideshow 
interval on the Options screen. The default value is 5000 msec.   After clicking, the slideshow 

button shows the pause symbol  . Clicking the button showing this symbol stops the 

slideshow, as does clicking the ESC key while the cursor is over the slideshow button. During the 
slideshow, all controls except the slideshow button are disabled.  
 
Images may be zoomed to a maximum of 3x by dragging the grey square in the scroll bar at the 
bottom of the screen, or by clicking the Up arrow button to zoom in or the Down arrow button 
to zoom out: 

 
Figure 42 Zoomed image display 
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Adding Selected Tags To All Input Data 
To add selected tags to all loaded items, check the tags required for the item from the list 
shown in the Tags section of the main screen. When any tag is selected, the Add Selected and 
Delete Selected button are enabled.  Clicking Add Selected shows a confirmation screen 
indicating the operation mode as shown below: 

 
Figure 43 Operation Mode Confirmation Screen 

The operation mode may be changed by clicking the Options button to show the screen in 
Figure 52. Checking Do Not Show This Screen Again will prevent the confirmation screen from 
being shown.  

Single Input Files 
If a single file is the selected item, the name of the item changes after tagging to include the tag 
string as shown below, and the tag string itself is shown in the tag text box. The tag !TS! is used 
as a marker to identify files tagged by SetTags. Multiple tags are separated by commas. 

 
 

 
 
Figure 44 Single file before adding Logos  (top) and after addition (bottom) 

If the file to be tagged already has a tag created by SetTags, the option to append the selected 
tag to the existing one or replace it is offered as shown below: 

 
Figure 45 Option screen to select  replacement of or appending  and existing tag 
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The selected tag is only appended if it is not present in the existing tag. 

Replacing Files Already Tagged 
If a tagged file is replaced rather than edited (as can happen when organisation logos or 
templates are changed), the new file should be placed in the same folder as the one it is 
replacing (which has tags included in its name) without any tags being added. The required tag 
should then be added by SetTags, and the new file with the selected tag in its file name will 
replace the old one.  
 
If the tags are added manually and the new file replaces the old one, any shortcuts pointing to it 
will not find the new file, as its identity as seen by the shortcut uses a unique file identifier, not 
the file path. In this case the shortcut will be removed by purging (see page 46). 

Same File Name in Different Folders 
Files with same name are commonly found in different folders. When these are tagged in Copy 
or Move mode, the facet folder sub-folder with the tag name will contain files with bracketed 
sequence numbers added to the file names before the file extension to distinguish them. In any 
of the other modes, a sequence number will be added to shortcut name for the second or 
subsequent files. 
 

Folder Contents 
If the selection is a folder, the following screen asking if the tagging is to be applied recursively 
to files in all sub-folders is shown: 

 
Figure 46 Application of tags to files recursively or to files in folder only 

 
Application of the tags can be stopped by clicking the Stop button below Add Selected, which is 
enabled when the tagging starts. The progress of tagging is shown below the tag grid, and the 
file name at the top is the file name after tag addition.  Note that changes to file name by an 
application may not result in the change being visible in Windows Explorer unless the display is 
refreshed by clicking F5. 
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Options Available from Tags Box 
The main functionality provided in the Input Data Actions and View boxes can be accessed by 
right-clicking in the Tags list to show the following context menu 

 
Figure 47 Tags box context menu 

If multiple tags are selected, the display may use a criteria of OR and AND for display depending 
on the setting of the Tag Conjunction box below the tag list. 
 
Selecting Option 2 shows either all tagged files with the selected tags, or only those files 
appearing in the input data. Further help is available from the Info menu items shown to the 
right of menu options: 

 

Auto-Tagging 
If option 6 (Auto-Tagging) is selected, the screen below allows users to select which rules to 
apply to the text content of the item and edit them if necessary: 

 
Clicking Apply applies the selected rules (rules with a check mark beside them) to the files 
shown in the grid. While the tagging is running, a Stop button appears below the Add/Edit Tags 
button. Clicking this stops processing. 

 
 
Note that folder items have no text content and URL text content may be missing or unexpected 
for reasons discussed earlier. 
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Delete Operations 
Tags are only removed from files by this operation. They are not removed from the tag list by 
this deletion. If tags are to be removed from the available list, click the Add/Edit Tags button. 
After Delete operations, SetTags is set to have no input data loaded. Note that changes to file 
name by an application such as SetTags from deleting tags may not result in the change being 
visible in Windows Explorer unless the display is refreshed by clicking F5. The Delete process for 
multiple files may be stopped by clicking the Stop button above Delete Selected. 

Delete Selected  
The Delete Selected button removes selected tags from input file(s) , from files within or below 
loaded folders or from all files to which the selected tag(s) have been applied. This button is 
only enabled if at least one tag is checked from the list shown in the grid.  

Delete All Tags 
The menu item Edit->Delete All Tags removes all tags from file(s) directly loaded, from files 
within or below loaded folders or from all files to which any tag has been applied. Note that no 
items need to be loaded for this operation to be enabled. Delete operations for All files may 
affect files not included in the input data. 
 

Creating the Facet Folder 
A facet folder and a set of sub-folders can be created from a set of loaded files containing tags 
via the menu item Edit->Create facets. This may be necessary if a collection of tagged files is 
moved to a different server and the existing shortcuts in the facet folder will not find their 
targets with the selected operation mode. In this case, a new, empty, facet folder should be 
specified. A screen will appear confirming that existing tags will be deleted from the database: 

 
 
After closing the Facet Folder screen and selcting Edit->Create Facets, a confirmation screen will 
appear: 

  
 
After confirmation, an option screen if the loaded files are folder contentswill appear: 
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 Selecting Yes will create sub-folders corresponding to tag names and populate them with 
shortcuts pointing to the files. Selected files without tags will not be processed. If tags do not 
exist in the current database to match those present in the files they will be created. 
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Facet Folders 
The Facet folder is created automatically on startup  at 
C:\Users\<UserName>\AppData\Roamind\SetTags\Facets for desktop licenses if it does not  
already exist.  It is the parent folder for a number of sub-folders which have the names of tags. 
The content of the sub-folders is determined by the Operation mode tab of the Options screen 
described on page 49.   Changes to tags are reflected in changes in the tag string in the file 
name, and by changes to the content of each sub-folder. If the Operation Mode uses Mapped 
Drive, Server Name or Relative Path shortcuts, the sub-folders contain shortcuts to files having 
that tag, thus allowing files with particular tags to be located by browsing rather than search.  
An example of a facet folder (Facets1) is shown below. This folder contains sub-folders, each 
with the name of a tag 

 
 

The sub-folders provide a way of finding tagged documents by browsing with Windows Explorer 
rather than using search. The content of sub-folder New Tag 4 is shown below: 

 
Each tag sub-folder contains a shortcut to the file with that tag, using the name of the file (with 
extension) for the shortcut. Where two different files have the same name and the same tag, a 
sequence number is added just before the file extension (eg Error.png(1), Error.png(2)). The 
Modified dates of the shortcuts are set to the Modified dates of the target files 
Tags are added to the names of the file as shown below: 

 
 
In Mapped Drive or Server Name shortcut mode, shortcuts will find their target if it has been 
moved or renamed within the file share or storage device, the structure is robust against 
renames or relocations of the tagged files 
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Setting Location 
The Facet folder location can be changed by clicking on the Edit->Facet Folder menu item to 
show the following screen. A new folder location can be selected using the Browse.. button. 

 
Figure 48 Facet Folder definition screen 

The View button launches Windows Explorer in the facet folder to show the sub-folders with the 
names of tags: 

 
Figure 49 Viewing Facet Folder with Tag sub-folders 

Purging the Facet Folder 
In Mapped Drive Letter, or Server Name mode, it is possible that the shortcuts contained in the 
facet folder point to files which have been deleted or moved to another server, in which case 
the shortcut will not open the desired file and will display the screen below: 

 
Figure 50 Message shown when shortcut target deleted or moved to another server 

Clicking the Purge button tests whether the targets of all shortcuts created in Mapped Drive 
Letter or Server Name modes below the facet folder point to targets which are still on the same 
server as when the shortcut was created. If not, the screen shown in Figure 50 is displayed, and 
the Yes option to delete the shortcut should be selected. In addition, purging removes pointers 
to emails which have not had tags applied or which are no longer accessible. 

 
Purge also offers the option to delete any tags from the list which have not been applied to any 
files. 

Changing Shortcut Target Drive Letters 
 
If a set of facet shortcuts is generated on a removable drive, the mapped drive letter may 
change if the drive is connected to a different computer or if different peripherals are 



SetTags User Manual 

Commercial-in-Confidence 47 Aleka Consulting 
  www.alekaconsulting.com.au 

connected to the same computer. The change in drive letter will result in shortcuts failing to 
find their targets when clicked. The shortcut targets can be changed in to use the new drive 
letter by selecting the new drive letter from the dropdown box, which shows all current drive 
letters for the computer, selecting one  and clicking Apply: 

 
Figure 51 Changing facet folder drive letter 

Using the Mapped Drive letter rather than Relative Path allows the thumbnail of the shortcut 
target file to be shown in the shortcut itself, allowing easy inspection of image files with a 
particular tag. 
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Exporting Tagged Files 
 
Files which have been tagged can be exported as a Zip file. Tagged folders and emails are not 
included. All files are contained within sub-folders of a Tagged Files folder. Each sub-folder has 
the name of a tag and each contains files with that tag. Tag names are not included in the file 
name. The export facility is accessed via the File->Export menu item. The exported file can be 
forwarded to users who do not have Set Tags installed but wish to access the files grouped by 
tag. 
 
 The content of  an example exported Zip archive is shown below: 
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Options Screen 

Operation Mode 

 
Figure 52 Operation Mode tab 

This tab is used to define how the shortcuts access the target files, or allow the user to copy or 
move files into the facet folders. In all Shortcut modes the facet folder subfolders contain 
shortcut files, whose icons contain an arrow in their bottom left corner as shown below: 

                           
Figure 53 Shortcuts in Facet Folder Subfolder in Details view (left), Medium Icons(Centre) and Large Icons(Right) 

Note that attaching shortcuts to emails will not allow the email recipient to view the files.  
The operation modes are as follows: 

Shortcut using Mapped Drive Letter 
 This is the  default mode where the Facet Folder and tagged files both reside on the local drive 
of the computer on which SetTags is installed, or on the same shared drive (often called the G: 
drive within organisations). If the location or name of the tagged file or shortcut changes but the 
file or shortcut remains on the same drive, the shortcut will still work. Where mapped drive 
letter shortcuts are created on a removable drive which does not have a constant drive letter 
across computers, the drive letter can be changed using the Change Mapped Drive Letter option 
on the Facet Folders screen shown on page 47.  

Shortcut using Server Name 
This option is used where  files have been tagged on different mapped drives and the drive 
letter used for mapping may change. The UNC path of the target file can be used as the target. 
This includes the name of the server and has the form: 



SetTags User Manual 

Commercial-in-Confidence 50 Aleka Consulting 
  www.alekaconsulting.com.au 

 
\\servername\sharename\folder\subfolder\file 
 
 If the location or name of the tagged file or shortcut changes but the file or shortcut remains on 
the same drive, the shortcut will still work. 

Change/Copy Database 

 
Figure 54 Change/Copy Database screen 

This screen allows the user to copy or change the database used by the application. 

Copy 
The Browse button allows the use to select a location to which the current database can be 
copied. Once it has been selected, this location appears in the ‘Copy Current Database to’ text 
box.  Clicking Copy then executes the copy. This functionality can be used to copy a database 
onto a removable drive so that slideshows can be shown from any computer with SetTags 
installed. However, the Facet Folder location will have to be changed to use the drive letter 
assigned to the removable drive on a different computer. 

Change Database 
 New database names can be selected from the dropdown, which contains all the database 
names which have been the change destination. Clicking Save when “New or Existing..” is 
selected from the combo box creates a new database with this name if the name does not exist. 
In this case, an empty database is created, using the default facet folder location. A non-existent 
name is created as the default when browsing by adding a sequence number to the current 
database path, as shown below. License information from the current database is copied to the 
new one. The default browse folder is the default location for databases, which is  
(C:\Users\<user>\AppData\Roaming\FindAlike). All databases have the extension .vdb5. Note 
that only the file name should be specified for a new database after browsing to a new folder. 

file://servername/sharename/folder/subfolder/file
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If the suggested new database name is not used, an existing database may be selected to open. 
This allows the use of a completely separate set of tags. Note that the application is restarted 
after changing the database. 
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Workgroup Operation 
 
In Workgroup mode, only one user (Workgroup Master) can change tags. For other users, tags 
are read-only, allowing central management. All users access the same tag list stored on a 
network database accessible to all users. If files or folders accessible to multiple users are to be 
tagged, the facet folder must be in a location accessible to all users. This may be a shared disk 
drive accessed via a Local Area Network (LAN). Mail messages are stored in the local databases  
and are not shared between multiple users. 
 
If SetTags is being used by multiple users who do not share access to filesystem storage but 
instead share cloud storage (such as Microsoft SharePoint, Microsoft Teams or DropBox), URLs 
of documents in cloud storage can be tagged and have descriptions added which can then be 
shared between users. In order to do this, all users must have access to a SQL Server Network 
database, which may be on a Virtual Private Server. The setup of such a database is described in 
the document SetTags Prep Install Support. In this case a Cloud license should not be used, and 
individual users will access facet folders in their own local storage. However, the tag list will 
come from the Network database. 

Setting Workgroup Licenses 
On installation, SetTags creates a demo license for each user, with a locally accessible facet 
folder. The Workgroup Master license should then be installed by the user who will administer 
the set of tags which can be applied. A SQL Server database should then be created in a location 
accessible to all workgroup users using the script provided in the document Set Tags Prep Install 
and Support. One the Workgroup Master license is installed, the Network database should be 
set to the SQL server database. If the workgroup share disk storage, a facet folder should be 
created in a location accessible to all workgroup users. Other Workgroup users should then 
install their Workgroup licenses and set the Network database to the newly created SQL Server 
database and the Facet folder to the location specified by the Workgroup Master user, if there is 
commonly accessible  and storage. If not, individual Workgroup users will retain different Facet 
folders and may only share tagged URLs with other Workgroup users 
 

Workgroup Access Control 
In a multi-user environment, not all users have access to all items. Access control for tagged files 
and folders can be set by the Workgroup Master user setting permissions on the facet folder 
sub-folders via Windows properties which can be set by right-clicking: 

 
If a user has no read access to a facet sub-folder, the tag will not appear in the tag list. If there 
are individual files to which the user does not have read access in a folder which is accessible, 
these files will not be listed as folder contents and will not appear in the SetTags grid. 
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A Workgroup license is required for multi-user operation, or if a single user wishes to access 
files on a network drive. For multi-user operation, a single user is designated the Workgroup 
Master user. This user can edit tags and define facet folder location and has all the capability of 
a desktop individual license. Other users receive a Workgroup license via a script which writes 
registry values. Workgroup users have restricted functionality as detailed below:  

Differences between Desktop and Workgroup Licenses 
Desktop Workgroup Workgroup Master 

No access to files on 
servers – local machine 
(including attached USB 
drives) only. 

Access to files and folders on 
file servers. 

Access to files and folders on 
file servers. 

Can access single Vista 
database only as local 
and network database    

No user control of databases. 
Uses  local Vista database and 
SQL Server database as 
network database 

Can access Vista or SQL Server 
databases as local and 
network database    

   

Full control of tags and 
tag filters 

No editing of tags, local option 
for tag filter 

Tags and network tag filters 
centrally managed by 
Workgroup Master user. 

User license stored on 
local database. 

License stored on network 
database.  

License stored on network 
database. 

No additional database 
required. 

Access to a SQL Server 
database required (can be SQL 
Server Express). 

Access to a SQL Server 
database required (can be SQL 
Server Express). 

Facet Folder on local 
drive by default 

Workgroup Users access facet 
folder specified by Workgroup 
Master user 

Can define facet folder and set 
permissions for individual tags 

Workgroup Masters and Other Users 
 Where a Workgroup license is being used with a single user, the user is a Workgroup Master 
user who has full capability to change facet folder locations and manage tags. Where centralised 
control of tag management and shared facet folder location is required, the Workgroup Master 
should access a SQL Server Master database as the  Network database. The database access 
credentials should support creation and modification of tables for the database. If tagged folder 
and files are to be shared, the Workgroup Master User should also specify a facet folder location 
which is accessible to all other users on a shared drive. If SetTags is only being use to tag URLs,  
a globally accessible facet folder is not required. Other Workgroup users will access their local 
VistaDB database and the network database with a SQL Server connection string. The licensing 
limit for Workgroup licenses limits the number of different accounts accessing the SQL Server 
Master database over a 24 hour period to the number specified in the license. 

Local and Network Connections 
The installation of  SetTags uses a default VistaDB database at 
C:\Users\UserName\AppData\Roaming\FindAlike\FindAlike.vdb5. A desktop license allows this 
to be changed, but the Network database is always the same as the Local database. A 
Workgroup Master license allows the use of a SQL Server database or a Vista database as the 
local and network database. 

Workgroup Licensing 
Installation of SetTags generates a Desktop demo license. The Workgroup Master should then 
enter their license key and set the Network database to an accessible SQL Server database. 
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Figure 55 License screen after entry of Workgroup Master license 

Tag Filter 
For Workgroup license, users may use the centrally defined Tag Filter options by selecting 
Network as the Filter source: 

 
Figure 56 Filters centrally defined from Network with no editing allowed 

By selecting Local as the Filter Source, a filter unique to the user can be defined and edited: 

 
Figure 57 Filters locally defined and editable 

The Workgroup Master user can make changes to the filters which will be visible to all 
Workgroup Users. 
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Appendices 

Errors 
Errors generated by any SetTags operation can be viewed by clicking the View-> Errors menu 
item as shown 
below:

 
Figure 58 Errors from Current Instance 

The default option is to show only errors which have occurred during the current SetTags run, 
(Current Instance in the combo box to the right of the error display but All Errors can also be 
displayed: 

 
Figure 59 Display of all errors 

Copying Tagged Files 
As tags are stored in the file name, copying a file with Windows Explorer will result in the “Copy 
being appended before the dot separating the file from the extension. Although the tags appear 
in the file name, a shortcut to the file will not be created in the appropriate facet folder and it 
will not be visible if files with any of the tags appearing in the name are selected. To ensure that 
copied tagged files appear in this case, the tag (or tags) should be re-applied to the copied file. 
In this case the tag name string will appear before the ”  – Copy”  part of the name as shown 
below: 
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Known Bugs and Workarounds 

Warning message when tagging files stored on USB drive 
USB drives often use the FAT32 (File Allocation Table) filesystem rather than  the NTFS (New 
Technology File System)  format used by hard drive and computer internal storage. The FAT32 
filesystem does not support writing of file metadata to the same extent that NTFS does. If files 
are stored on a FAT32 filesystem, a warning message is generated that failures may result when 
deleting tags from files which have been moved, as file metadata is used to indicate the location 
of shortcuts pointing to files. If files have not been moved, then no problems will arise. For 
maximum flexibility, USB drives should be formatted as NTFS filesystems, but this will erase any 
data stored on them. Metadata setting on FAT32 drives is much slower than on NTFS drives. 
 
 
 


